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WELCOME TO CALC2!

CALC2 is a calculator that lets you take 
advantage of the easy-to-use Macintosh interface. 
Menus and buttons allow simultaneous access to 
as many as four different mathematical functions. 
A scrolling, resizable “paper tape” window lets you 
see all your calculations. You can print and save 
your work. You can copy and paste your 
calculations into your word processor or any other 
application that accepts text files.  CALC2 is easy 
to use, but has lots of features. Print out this 
manual if you want to.

OVERVIEW

figure 1

When you launch CALC2, what you’ll see is illustrated in figure 1, above. The scrolling “tape” 
window is on the left. In the center are the four function buttons and on the right are the four pop-
up menus. The Hide Body and Help buttons are near the bottom. You will also see the familiar , 
File and Edit menus on the menu bar at the top of your screen. 

The POP-UP MENUS

The four pop-up menus all list the same eleven built-in mathematical functions. In figure 2, 
below, we dropped a pop-up menu to show the math functions. “x*x” stands for “squared.” “K” means 
constant (you can select your own constants).   “e^x” means “e raised to the power of x.”   “rand” is 
the random number generator. 
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figure 2

THE FUNCTION BUTTONS

The pop-up menus control what appears in the function buttons. In figure 2, above, sine is 
selected in the top pop-up menu and the word “sine” appears in the top function button. Just below, 
the % function is chosen in the displayed menu and “15%” appears in the function button (it’s easy to 
specify which percentage — more later).  

Each function button is assigned a permanent command key. The top button is always ⌘-1. 
The second button is always ⌘-2, the third button 
⌘-3 and the bottom button is always ⌘-4.

USING FUNCTIONS

To enter a function, click its function button or type its ⌘-key shortcut. Then press the equal 
key (=) to display the answer. 

Let’s say you want the square root of 33. In figure 2, square root already appears in the third 
function button. Just type “33”. Then click your mouse in the third function button (or press ⌘-3). Now 
press the equal key. (The Return and Enter keys also serve as equal keys.) What you’d see in the tape 
window is shown in figure 3, below. CALC2 figured the answer to 10 decimal places.
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figure 3

Now you want the cosine of 60 degrees.  First you type “60”, which appears in the tape 
window. Cosine isn’t in any function button, so you select “cos” from any of the pop-up menus. A 
function button now says “cosine”. Click that button, then press ‘=’. Figure 4, below, shows the result.

figure 4

Note that your previous calculation of the square root of 33 is still visible.

Now for a percentage calculation. You want to subtract 7% from 105. But the second function 
button has 15% entered! Or, if you just launched CALC2, the top function button simply says “per 
cent.” Doesn’t matter. Just click “%” on the pop-up menu and a dialog box opens.  See figure 5, below. 
Enter “7” in the dialog box and click “OK” (or press the Return key).  “7%” now appears in the function 
button. You could have selected “%” from any of the other pop-up menus. The same dialog box would 
open.

figure 5

By the way, don’t type “%” in the dialog box. It’s not necessary and CALC2 will just beep at 
you. 
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To subtract 7% from 105, type “105”, then minus (-), then click the “7%” function button (or 

press its ⌘-key equivalent), then press “=”. The results appear in figure 6, below.

figure 6

As you can see in figure 6, the “tape” window’s scroll bars become active after you’ve entered 
enough lines. 

You’ve also seen that to use the % function, you must enter an operand between the number 
and the percent. If you type 105 and click the percent button, you’ll hear a beep because CALC2 needs
to know if you want to add, subtract, multiply or divide by 7%.

Selecting K on a pop-up menu opens another dialog box. Type your constant and close the 
dialog box. Your constant will appear in the corresponding function button. Figure 7, below, shows the 
constant dialog box and resulting function button and pop-up menu. 

 figure 7
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In figure 7, we entered 2.54, the number of centimeters to the inch. If you want to figure out 

how many centimeters are in a foot, just type “12*”, click the function button and press the equal key.  
The answer of 30.48 appears in the tape window.

You can keep up to four different constants handy by selecting K from each pop-up menu and 
entering a different constant in each dialog box. You could also keep four percentages handy the same 
way.  

The last function to use a dialog box is the random number generator, or rand on the pop-up 
menus. If you select rand, a dialog box allows you to select the range of random numbers that you 
want. See figure 8, below.

figure 8

Positive random numbers is the default selection. You can have all three selections available by
selecting rand from three pop-up menus and selecting a different range from each dialog box.

ABOUT THE EQUAL KEY (=)

You may wonder why you have to press the equal (=) key after you enter a function. If you 
type 33 and click the square root button, shouldn’t you get your answer immediately? That would be 
fine if you just want the square root of 33. CALC2 allows you to do more powerful calculations. If you 
want the square root of 33 multiplied by the cosine of 60 degrees, and to add 7% to that and divide 
the result by 2.54, you will need to press the equal key to let CALC2 know you’re done. See figure 9, 
below.

figure 9
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If you are doing arithmetic, and not using any functions, most calculators, including CALC2, 

require you to press ‘=’ when you’re done. Consistency in requiring the equal key when you do use 
functions is easier to remember and allows complex calculations like the one in figure 9. 

GETTING HELP ⌘-H

To open CALC2’s help window, click the Help button. The Help button can be seen in figure 1, 
above, just below the pop-up menus. You can also open the help window by choosing Help... from the 
File menu or by pressing ⌘-H. 

figure 10

The Help window has a pop-up menu to let you quickly choose a help topic. Figure 10, above, 
shows a partial view of the help window, with the pop-up menu displayed. Select a topic from the pop-
up menu. It will appear in the help window. Much of the information in this manual is available in the 
help window, plus additional illustrations.

To close the help window, click the OK button, press Return, click the close box or press ⌘-W.

HIDE BODY and SHOW BODY ⌘-B

In figures 1 and 2, above, you can see the Hide Body button below the function buttons. 
Clicking the Hide Body button, entering  ⌘-B from the keyboard, or selecting Hide Body from the File 
menu hides the body of the 
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calculator and leaves only the “tape” window visible on screen. The size of the window can now be 
controlled by clicking in the zoom box or dragging the grow box.  This feature lets you save space on 
your screen by only showing the standard sized “tape” window, or lets you see more of your 
calculations by enlarging the window. You can also use the grow box to make the window smaller, if 
you want.

On the File menu, Hide Body is replaced with Show Body.  Selecting Show Body or entering ⌘-B will 
make the calculator reappear.

THE LIST OF COMMANDS WINDOW ⌘-K

Selecting Command Keys from the File menu, or pressing ⌘-K, opens a window that lists all of 
CALC2’s ⌘-key equivalents. See figure 11, below. 

figure 11

This window is not only a handy list of ⌘-keys. If you selected Hide Body, you must enter 
functions using the function buttons’ ⌘-key equivalents (⌘-1 through ⌘-4). The top of the List of 
Command Keys window displays the four currently selected functions. If you are using the Percent, 
Constant or Random functions, then the actual percentage, constant or range of random numbers you 
chose will appear in the list.  If you are using π, then 3.1415926536 (π to 10 decimal places) appears in
the list.  If you change a function, the Command Key list immediately reflects that change. 

To close the window, click the OK button, press Return, click the close box or press ⌘-W.
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PHILOSOPHY BREAK

Why does CALC2 bother with four pop-up menus plus four function buttons instead of giving 
each function its own button?  Well, you’ve already seen how the menus and buttons  allow you to 
have up to four constants, or four percentages handy at one time. It is also easier to hit four big 
buttons than eleven itty-bitty buttons. CALC2’s design gives you the choice of using
⌘-key substitutes if you prefer that to clicking the mouse. The ⌘-key substitutes make the Hide Body 
feature possible. 

In other words, CALC2 was designed to be  Macintosh software rather than an imitation of a 
hardware calculator.

Enough philosophy. Time for more features.

DUPLICATE TOTAL ⌘-D

To re-enter the previous total, select Duplicate Total from the Edit menu or press ⌘-D. Your 
total will re-appear on a new line as the first entry in a new calculation. Duplicate Total is only available
after the equal sign (or the equivalent Enter or Return key) has been pressed. 

This command makes it easy for you to continue working with a total without having to re-type
it, while preventing a total from inadvertently being included in the next calculation.

MONEY  ⌘-M

To confine CALC2’s answers to two decimal places, select Money 
(⌘-M) from the Edit menu. A check mark () will appear next to Money on the Edit menu.  Now, no 
matter what figures you enter, the answer is rounded to two decimal places. We call this feature 
“Money” because most people use it for financial transactions.

To return to floating decimal answers, select Money (⌘-M) again. Money  will no longer be 
checked.

CLEAR AND DELETE 

In case of an error in typing or in entering a function: To clear everything, press either the clear
or escape key.  To delete the last line, press the delete key. Here’s what each key does:

clear or escape key: “•CLEARED•” will appear in the Tape Window. CALC2 will not consider anything 
previously entered. 

delete key (backspace key on earlier Macs): Deletes the last line. Only the last line can be deleted.  
Use the clear or esc key to start over. 
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MENU SUMMARY

CALC2 has three menus: the familiar Apple ( ), File and Edit menus.

The Apple Menu

The Apple menu contains the About CALC2... selection. Selecting About CALC2... opens a 
dialog box that reminds you that CALC2 is copyrighted and is shareware. If you keep it more than 15 
days send $20.00  to: 

Nigel Gusdorf
1505 Arcadia Avenue

Austin, TX 78757

(You were wondering when I was going to bring this up.)

The File Menu

The File menu is illustrated in figure 12, below.

figure 12

Help... opens the help window.
Hide Body leaves only the scrolling “tape” window visible on screen. Hide Body is replaced by 

Show Body. Show Body makes the calculator reappear.
Command Keys opens a window with a complete list of CALC2’s 

⌘-key substitutes plus a list of the four currently selected functions.
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New opens a new CALC2 file. 
Open... lets you open previously saved CALC2 files.
Save lets you save your work as a CALC2 file. When saving for the first time, it lets you name 

the file and specify where it should be saved.
Save As... lets you save your file under a different name or in a different location.
Page Setup... lets you specify how your work should be printed.
Print lets you print your work.
Quit shuts down CALC2. If you have unsaved changes, a dialog box will open to give you a 

chance to save your work. To quit immediately without opening this dialog, hold down the shift key as 
you select Quit. Be very sure you want to shift-Quit, because any unsaved changes will be lost!

The Edit Menu

The Edit menu is illustrated in figure 13, below.

figure 13

Cut removes highlighted text from the tape window and copies it to the clip board.
Copy copies highlighted text from the tape window to the clipboard.
Paste inserts text from the clipboard into the tape window.
Clear removes highlighted text from the tape window. It will not be copied to the clipboard: it is

deleted.
Select All selects (highlights) everything in the tape window.
Duplicate Total enters the previous total as the first line in a new calculation.
Money rounds off all answers to two decimal places. Selecting Money again will return CALC2 

to floating decimal answers.
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EDITING

You can copy your work to the clipboard and paste it into any application that accepts text 
files. We recommend that you use the Copy command because the Cut command will remove selected 
text and numerals from the Tape Window. If you cut or clear selections from the tape window, CALC2 
won’t take that into account, which can lead to nonsense answers. 

Pasting into CALC2 is not recommended. CALC2 can’t perform math operations on pasted text 
or numbers. You can paste in the 23rd Psalm, but you can’t multiply it by two and get the 46th Psalm! 

If you use Cut, Paste or Clear, press the clear or escape key before continuing. This will prevent
future errors.

FUNCTIONS SUMMARY

The following table explains the 11 mathematical functions built into CALC2.

Note: “Enter” means click a function button or type its command key equivalent (⌘-1 through  ⌘-4).
   
   Menu      Function   
 Symbol      Button                Explanation

% xx% CALC2 asks you to type the percentage you want. 
That percentage appears in the function button. 
Type a number, type an operand (+,-,*, or /), and 
enter your percentage. CALC2 will perform the 
percentage calculation.

√ square rootType a number and enter square root. CALC2 
calculates the square root of that number.

x*x square Type a number and enter square. CALC2 
calculates the square of your number.

K xxx CALC2 asks you to enter a number. That number 
appears in the function button. Enter K whenever 
you want that number in your calculations. 

π 3.1415926536 Pi calculated to 10 decimal places. Enter π whenever you need it.
e^x e to x power Type a number, enter e^x. CALC2 calculates e to the power 

of your number.
logX natural log of

X 
Logarithm to the base e. Type a number, enter logX. CALC2 
calculates the power of e equal to your number.

sine sine Type a number, enter sine. CALC2 calculates its 
sine, in degrees.

cos cosine Type a number, enter cos. CALC2 calculates its 
cosine, in degrees.

arc arctangent Type a number, enter arc. CALC2 calculates its 
arctangent, in degrees.

rand pos. (or
neg.) rand.

no.

Random number generator. CALC2 asks you to 
select a range of random numbers. That range 
appears in the function button. Enter rand. CALC2 
will generate a random number for you.
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Don’t forget to press the equal (=) key when you are ready for the answer.

You may also use the Return or Enter key instead of the equal key.

SETTLING UP

CALC2 is shareware. If you keep it more than 15 days, please mail $20.00 US to:
Nigel Gusdorf

1505 Arcadia Avenue
Austin, Texas   78757

CompuServe 71214, 2324

CompuServe customers can register their copy of CALC2 on-line. GO SWREG takes you to 
CompuServe’s Shareware Registration Database. CALC2’s Registration ID is 756. See the 
accompanying CompuServe ReadMe file for details.

Thank you for supporting shareware.

CALC2 is copyright 1992, 1993 by Nigel Gusdorf.
This manual ©1993 by Nigel Gusdorf.
Macintosh is a registered trademark of Apple Computer, Inc.
CompuServe is a registered trademark of CompuServe Inc.


